吉本集の個人ブログ
Web制作の技術について書いています。たまに日記も書きます。

jQuery 2.x系とjQuery 1.x系

2013年8月23日 / category : jquery, lab, reference-jquery

jQuery 2.x系がリリースされました。2.x系はIE8以下をサポートしないようですが、実務ではまだまだIE8は外せないので、しばらくは2.x系と1.x系の使い分けが必要になりそうです。

<!--[if lt IE 9]>
<script src="http://code.jquery.com/jquery-1.9.1.min.js"></script>
<![endif]-->
<!--[if gte IE 9]><!-->
<script src="http://code.jquery.com/jquery-2.0.3.min.js"></script>
<!--<![endif]-->

上記のようなブラウザによって2.x系と1.x系を振り分ける使い方が提案されているようです。
今後も、1.x系はバージョンアップしていくようなので、IE8が実務で外せないまでは、こちらの振り分けで読み込むこととなりそうですね。